USB-Irda Adapter sendet aber empfängt nichts!

  • Hallo!
    Ich habe einen USB-Irda Adapter unter Win 98SE erfolgreich installiert, bekomme aber mit meinem Laptop oder meinem Handy nur eine einseitige Verbindung zustande. Ich kann nur Dateien senden, aber nichts empfangen. Ist das ein bekanntes Problem? Hat jemand eine Idee????

  • Zitat

    Original von Gast
    Ich habe einen USB-Irda Adapter unter Win 98SE erfolgreich installiert, bekomme aber mit meinem Laptop oder meinem Handy nur eine einseitige Verbindung zustande. Ich kann nur Dateien senden, aber nichts empfangen. Ist das ein bekanntes Problem? Hat jemand eine Idee????


    Erkennt der 'Infrarot-Monitor' das Handy, wenn es in Reichweite ist? Dann würde nämlich das physikalische Empfangen klappen und ich würde es auf die Software schieben.


    Was für ein Infrarotport ist es denn? Hat er den Sigmatel-Chipsatz drin?

  • Danke für die Antwort.
    Das Handy wird eindeutig erkannt, es ist auf dem Ir-Monitor auch ein kurzzeitiger Empfang mit Anzeige der Übertragungsgeschwindigkeit erkennbar, ein echter Datenaustausch findet aber nicht statt. Der Empfänger/Sender ist ein VISHAY 6102F, der Chip von SIGMATEL STir4200S. Weiter steht auf dem Chip LA9H00002, darunter 0412. Meinst du die Treiber-Software? Die Datei STIRUSB.SYS ist von Sigmatel, müsste also korrekt sein!? Liegt's vielleicht am BIOS? Meine Motherboard ist von Gigabyte GA-586ATE/ATM.

  • Zitat

    Original von Gast
    Das Handy wird eindeutig erkannt, es ist auf dem Ir-Monitor auch ein kurzzeitiger Empfang mit Anzeige der Übertragungsgeschwindigkeit erkennbar, ein echter Datenaustausch findet aber nicht statt.


    Wird auch den Name des Handys angezeigt?


    Scheinbar funktioniert sowohl Senden, als auch Empfangen kurzzeitig. Evtl. ist die USB-Stromversorgung oder auch eine Pufferung im USB-Infrarotport nicht in Ordnung.


    In Welche Richtung funktioniert der Datentausch? Vom PC zum Hando bzw. Laptop? Oder nur umgekehrt?


    Zitat

    Der Empfänger/Sender ist ein VISHAY 6102F, der Chip von SIGMATEL STir4200S. Weiter steht auf dem Chip LA9H00002, darunter 0412.


    Gut, dann hast Du Qualität, bei ebay wird auch ein - außerlich gleicher - USB-Infrarotport verkauft, der einen irgendwo in China für drei Reiskörner billgiger programmierten Microcontroller drinhat, aber kaum was leistet.


    Zitat

    Meinst du die Treiber-Software? Die Datei STIRUSB.SYS ist von Sigmatel, müsste also korrekt sein!? Liegt's vielleicht am BIOS? Meine Motherboard ist von Gigabyte GA-586ATE/ATM.


    Am Bios des Motherboards liegt es sicher nicht. Am Treiber vermutlich auch nicht. Wenn Du mir mailst, sende ich Dir allerdings die neuste Treiber-Version zu. Wenn Du einen USB-Hub mit Netzteil hast, dann schließ den Infrarotport doch mal testweise daran an (für den Fall, daß das Mainboard nicht richtig die Stromversorgung des USB sicherstellt). Wenn das alles nicht klappt, ist wohl der Infrarotport defekt (teste diesen doch mal an einem anderen Rechner).

  • kenne mich damit kaum aus, habe allerdings die erfahrung mit nem IR-drucker gemacht, dass es durch andere angemeldete geräte zu problemen kommen kann. bei mir war das damals so:


    der drucker wurde zwar erkannt, drucken ging aber nicht. das lag daran, dass ich auch die palm-software installiert hatte, und die den IR-port für den palm reserviert hatte. bis ich das raus hatte, verging einige zeit...


    außerdem könnte man noch einen anderen usb-steckplatz probieren. bei meinem handy ist es so, dass ich es nur an einem von beiden usb-plätzen anschließen kann, wenn ich z.b. bilder runter ziehen will. auf dem anderen stackplatz wird es zwar erkann, es läd auch den accu, aber datenaustausch ist nur bei dem einen steckplatz möglich.

  • Das mit der Stromversorgung klingt ein wenig nach der richtigen Problem-Ursache. Allein die Tatsache, dass das Senden auch einer längeren Datei vom PC zum Handy und Laptop einwandfrei und ohne Unterbrechung funktioniert, spricht dagegen. Das Handy und auch der Laptop werden eindeutig mit Namen erkannt und angezeigt. Auch die Verbindungsgeschwindigkeit wird angezeigt. Beim Empfang allerdings nur etwa eine Sekunde lang. Auch auf den anderen Geräten wird der Sendeversuch kurzzeitig angezeigt, danach erscheint die Meldung "Fehler aufgetreten" oder "Datei ungültig" oder "Verbindung unterbrochen". Kann es sein, dass der PC den Empfang von Daten über diese Art der Verbindung verweigert? Dies würde ich gerne wieder freischalten, wenn ich wüsste wie!

  • Habe Firewall ausgeschaltet, alle USB-Ports ausgetestet, alle möglichen anderen Programme, die mir irgendwie störend erschienen deaktiviert und überhaupt mal wieder eine lange Nacht gehabt. Damit hatte ich keinen Erfolg. Immernoch kein Datentransfer von Handy zum PC. Geht nur andersherum. Hatte dennoch einen Teilerfolg: Die Handysoftware von meinem Siemens M65 hat unter anderem einen Modem-Assistenten zum Herstellen einer Internetverbindung, der natürlich ersteinmal mein Handy nicht finden konnte. Nachdem ich ihm mitgeteilt habe am COM5 Port und nicht über Irda Port zu suchen hat er mir ein "GPRS via COM" Modem installiert und ich konnte eine stabile Internetverbindung, also in beide Richtungen herstellen. Über das vom Infrarotmoniter erkannte und eingerichtete "GPRS via Irda" Modem kann ich nach wie vor keine Verbindung herstellen. Hat vielleich jemand noch eine Idee???

  • Zitat

    Original von Dschen Reinecke
    Das hört sich so an, als sei die Treibersoftware des Infrarotports buggy.


    Mail mir und ich sende Dir für den Chipsatz die neuste Version zu.


    Danke für die Software!
    Konnte leider das Problem damit nicht lösen...
    I give up!